WordPress Sniplets Plugin <= 1.2.2 - Remote File Inclusion

sniplets

Software
Sniplets
Versions
<= 1.2.2
Disclosure date
2008-02-28
CVE
CVE-2008-1059
References
Credits
Classification
Remote File Inclusion
OWASP Top 10

Are your websites subject to this vulnerability?

Details

Because of this vulnerability in modules/syntax_highlight.php, the attackers can execute arbitrary PHP code via a URL in the "libpath" parameter.

Solution

Update the plugin.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.