API Monitor free
arrow right To plugin page
Not fixed

WordPress Button Widget Smartsoft plugin <= 1.0.1 - Cross-Site Request Forgery (CSRF) vulnerability to Cross-Site Scripting (XSS)

8.8
CVSS 3.1 score High severity
Monitoring Coming soon

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Button Widget Smartsoft
Type
Plugin
Vulnerable versions
<= 1.0.1
Fixed in
N/A
PSID
a3903345d30b
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A5: Broken Access Control
Publicly disclosed
2022-06-16

Details

Cross-Site Request Forgery (CSRF) vulnerability to Cross-Site Scripting (XSS) was discovered by Ryo Onodera (Cryptography Laboratory Tokyo Denki University) in the WordPress Button Widget Smartsoft plugin (versions <= 1.0.1).

Solution

Deactivate and delete. This plugin has been closed as of June 8, 2022 and is not available for download. This closure is temporary, pending a full review.

References

Vulnerability details

No other known vulnerabilities found for Button Widget Smartsoft.
Let us know if we missed something.

Report a vulnerability

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close