WordPress HT Slider Range for Amazon affiliates plugin <= 1.1.9 - Unauthenticated Reflected Cross-Site Scripting (XSS) vulnerability

slider-range-htapps

Software
HT Slider Range for Amazon affiliates
Versions
<= 1.1.9
Disclosure date
2021-04-16
CVE
CVE-2021-30134
References
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
CVSS 3.0 score

7.4

High

Are your websites subject to this vulnerability?

Details

Unauthenticated Reflected Cross-Site Scripting (XSS) vulnerability discovered by Frank Liauw in WordPress HT Slider Range for Amazon affiliates plugin (versions <= 1.1.9).

Solution

Update the WordPress HT Slider Range for Amazon affiliates plugin to the latest available version (at least 1.1.10).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.