WordPress Side Cart Woocommerce (Ajax) plugin <= 2.0 - Cross-Site Request Forgery (CSRF) vulnerability leading to Arbitrary Options Update

side-cart-woocommerce

Software
Side Cart Woocommerce (Ajax)
Vulnerable Versions
<= 2.0
Fixed in version
2.1
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A5: Broken Access Control
Disclosure Date
2022-01-13
CVSS 3.0 score

8.8

High

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Arbitrary Options Update discovered by Chloe Chamberland in WordPress Side Cart Woocommerce (Ajax) plugin (versions <= 2.0).

Solution

Update the WordPress Side Cart Woocommerce (Ajax) plugin to the latest available version (at least 2.1).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.