API Monitor free
arrow right To plugin page
Fixed

WordPress ShortPixel Adaptive Images plugin <= 3.3.1 - Subscriber+ Plugin Settings Update vulnerability

4.3
CVSS 3.1 score Medium severity
Monitoring Coming soon

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Type
Plugin
Vulnerable versions
<= 3.3.1
Fixed in
3.4.0
PSID
d3f25d3d67a6
Classification
Other Vulnerability Type
OWASP Top 10
A5: Broken Access Control
Required privilege
Requires subscriber or higher role user authentication.
Publicly disclosed
2022-04-25

Details

Subscriber+ Plugin Settings Update vulnerability discovered by Tien Nguyen Anh (Patchstack Alliance) in WordPress ShortPixel Adaptive Images plugin (versions <= 3.3.1).

Solution

Update the WordPress ShortPixel Adaptive Images plugin to the latest available version (at least 3.4.0).

References

CVE-2022-29417 Plugin changelog

No other known vulnerabilities found for ShortPixel Adaptive Images.
Let us know if we missed something.

Report a vulnerability

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close