WordPress Autopilot SEO for WooCommerce plugin <=1.5.1 - Multiple vulnerabilities

seo-for-woocommerce

Software
Autopilot SEO for WooCommerce
Vulnerable Versions
<=1.5.1
Fixed in version
1.6.0
Classification
Multiple Vulnerabilities
OWASP Top 10
A1: Injection
Disclosure Date
2021-09-20
CVSS 3.0 score

8.8

High

Possible with customer (WooCommerce) role user.

Are your websites subject to this vulnerability?

Details

Multiple vulnerabilities (Authenticated Arbitrary WordPress Options Change, Read and Deletion / Authenticated User Enumeration / Authenticated Plugin Settings Change, Import and Export) were discovered by Jerome Bruandet (NinTechNet) in WordPress Autopilot SEO for WooCommerce plugin (versions <=1.5.1).

Solution

Update the WordPress Autopilot SEO for WooCommerce plugin to the latest available version (at least 1.6.0).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.