WordPress Internal Links Manager plugin <= 2.1.0 - Multiple Authenticated Stored Cross-Site Scripting (XSS) vulnerabilities

seo-automated-link-building

Software
Internal Links Manager
Versions
<= 2.1.0
Disclosure date
2020-12-28
CVE
CVE-N/A
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)

Are your websites subject to this vulnerability?

Details

Multiple Authenticated Stored Cross-Site Scripting (XSS) vulnerabilities found by Chevon Phillip in WordPress Internal Links Manager plugin (versions <= 2.1.0).

Solution

2020-12-28 - we were unable to find a patched version of this plugin. Notification from WordPress.org - "This plugin has been closed as of December 28, 2020 and is not available for download. This closure is temporary, pending a full review."

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.