API Monitor free
arrow right To plugin page
Fixed

WordPress Responsive Menu plugin <= 4.1.7 - Nonce token leak leading to arbitrary file upload, theme deletion, plugin settings change vulnerability

8.3
CVSS 3.1 score High severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Type
Plugin
Vulnerable versions
<= 4.1.7
Fixed in
4.1.8
PSID
5dbce19b2ebc
Classification
Sensitive Data Exposure
OWASP Top 10
A3: Sensitive Data Exposure
Required privilege
Requires subscriber or higher role user authentication.
Publicly disclosed
2022-03-16

Details

Nonce token leak leading to arbitrary file upload, theme deletion, plugin settings change vulnerability discovered by Dave Jong (Patchstack) in WordPress Responsive Menu plugin (versions <= 4.1.7).

Solution

Update the WordPress Responsive Menu plugin to the latest available version (at least 4.1.8).

References

CVE-2022-25602 Plugin changelog Vulnerability details

Other known vulnerabilities for Responsive Menu

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close