API Monitor free
arrow right To plugin page
Fixed

WordPress reSmush.it Image Optimizer plugin <= 0.4.5 - Authenticated Cross-Site Scripting (XSS) vulnerability

4.8
CVSS 3.1 score Medium severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
reSmush.it
Type
Plugin
Vulnerable versions
<= 0.4.5
Fixed in
0.4.6
PSID
c0960ac34e2f
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Requires high role user authentication like admin.
Publicly disclosed
2022-09-19

Details

Authenticated Cross-Site Scripting (XSS) vulnerability discovered by Raad Haddad (Cloudyrion GmbH) in WordPress reSmush.it Image Optimizer plugin (versions <= 0.4.5).

Solution

Update the WordPress reSmush.it plugin to the latest available version (at least 0.4.6).

References

Vulnerability details

No other known vulnerabilities found for reSmush.it.
Let us know if we missed something.

Report a vulnerability

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close