API Monitor free
arrow right To plugin page
Verified
Fixed

WordPress Rate my Post – WP Rating System plugin <= 3.3.4 - Race Condition vulnerability

4.3
CVSS 3.1 score Medium severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Type
Plugin
Vulnerable versions
<= 3.3.4
Fixed in
3.3.5
PSID
2f04882d9502
Classification
Other Vulnerability Type
OWASP Top 10
A1: Injection
Required privilege
Requires subscriber or higher role user authentication.
Publicly disclosed
2022-09-14

Details

Race Condition vulnerability leading to votes increase/decrease discovered by Nguy Minh Tuan (Patchstack Alliance) in WordPress Rate my Post – WP Rating System plugin (versions <= 3.3.4).

Solution

Update the WordPress Rate my Post – WP Rating System plugin to the latest available version (at least 3.3.5).

References

Other known vulnerabilities for Rate my Post – WP Rating System

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close