Security programs Bounty leaderboard API Protect

WordPress Product Configurator for WooCommerce Plugin <= 1.2.31 is vulnerable to Arbitrary File Deletion

Patch immediately High priority
Not known to be exploited Report an attack
Medium severity CVSS 3.1 score

Patchstack automatically mitigates this vulnerability with a vPatch.

Enable Protection


Update to fix
vPatch available

Update the WordPress Product Configurator for WooCommerce plugin to the latest available version (at least 1.2.32).

cydave discovered and reported this Arbitrary File Deletion vulnerability in WordPress Product Configurator for WooCommerce Plugin. This could allow a malicious actor to delete files from your website. If core files are deleted from your website, it could cause your site to break and stop functioning. This vulnerability has been fixed in version 1.2.32.

No other known vulnerabilities for this plugin


WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Alliance bounty platform and earn monthly cash prizes.

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close