WordPress Post SMTP Mailer/Email Log Plugin <= 2.8.7 is vulnerable to Broken Authentication

Note that this vulnerability occurs due to a logical mistake in the code. For this reason, all legitimate and illegitimate requests are blocked to cover all scenarios.

Patch priority: high
Resolve immediately High priority
Known to be exploited Active attempts logged
9.8
Critical severity CVSS 3.1 score

Detect and mitigate security vulnerabilities at scale with Patchstack!

Enable Protection

Patchstack is the official security point of contact for WordPress Post SMTP Mailer/Email Log plugin.

Solution

Fixed Update to fix
vPatch available vPatch available

Update the WordPress Post SMTP Mailer/Email Log plugin to the latest available version (at least 2.8.8).

Note that this vulnerability occurs due to a logical mistake in the code. For this reason, all legitimate and illegitimate requests are blocked to cover all scenarios.

Ulyses Saicha discovered and reported this Broken Authentication vulnerability in WordPress Post SMTP Mailer/Email Log Plugin. This can be abused by a malicious actor to perform action which normally should only be able to be executed by higher privileged users. These actions might allow the malicious actor to gain admin access to the website. This vulnerability has been fixed in version 2.8.8.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

0 present
11 fixed
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Bug Bounty to earn bounties and rewards!

Learn more
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu