WordPress Gutenberg PDF Viewer Block plugin <= 1.0 - Stored Cross-Site Scripting (XSS) vulnerability

pdf-viewer-block

Software
Gutenberg PDF Viewer Block
Vulnerable Versions
<= 1.0
Fixed in version
1.0.1
CVE
CVE-2021-24760
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)
Disclosure Date
2021-09-20
CVSS 3.0 score

5.4

Medium

Contributor or higher role user required.

Are your websites subject to this vulnerability?

Details

Stored Cross-Site Scripting (XSS) vulnerability discovered by apple502j in WordPress Gutenberg PDF Viewer Block plugin (versions <= 1.0).

Solution

Update the WordPress Gutenberg PDF Viewer Block plugin to the latest available version (at least 1.0.1).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.