WordPress Patreon WordPress plugin <= 1.7.1 - Reflected Cross-Site Scripting (XSS) vulnerability

patreon-connect

Software
Patreon WordPress
Versions
<= 1.7.1
Disclosure date
2021-03-26
CVE
CVE-2021-24229
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
CVSS 3.0 score

8.8

High

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability discovered by Jetpack Scan team in WordPress Patreon WordPress plugin (versions <= 1.7.1).

Solution

Update the WordPress Patreon WordPress plugin to the latest available version (at least 1.7.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.