WordPress Paid Memberships Pro plugin <= 2.6.5 - Reflected Cross-Site Scripting (XSS) vulnerability

paid-memberships-pro

Software
Paid Memberships Pro
Vulnerable Versions
<= 2.6.5
Fixed in version
2.6.6
CVE
CVE-2021-24979
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-11-23
CVSS 3.0 score

4.7

Medium

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability discovered by JrXnm in WordPress Paid Memberships Pro plugin (versions <= 2.6.5).

Solution

Update the WordPress Paid Memberships Pro plugin to the latest available version (at least 2.6.6).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.