API Monitor free
arrow right To plugin page
Not fixed

WordPress Opal Hotel Room Booking plugin <= 1.2.7 - Stored Cross-Site Scripting (XSS) vulnerability

4.1
CVSS 3.1 score Medium severity
Monitoring Coming soon

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Opal Hotel Room Booking
Type
Plugin
Vulnerable versions
<= 1.2.7
Fixed in
N/A
PSID
5a598010f868
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Requires contributor or higher role user authentication.
Publicly disclosed
2022-05-17

Details

Stored Cross-Site Scripting (XSS) vulnerability discovered by Ngo Van Thien (Patchstack Alliance) in WordPress Opal Hotel Room Booking plugin (versions <= 1.2.7).

Solution

Deactivate and delete. No reply from the vendor.

References

CVE-2022-29449 Plugin page

No other known vulnerabilities found for Opal Hotel Room Booking.
Let us know if we missed something.

Report a vulnerability

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close