WordPress Facebook for WordPress plugin <= 3.0.3 - Cross-Site Request Forgery (CSRF) leading to Stored Cross-Site Scripting (XSS) vulnerability

official-facebook-pixel

Software
Facebook for WordPress
Versions
<= 3.0.3
Disclosure date
2021-03-25
CVE
CVE-N/A
Credits
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
CVSS 3.0 score

8.8

High

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) leading to Stored Cross-Site Scripting (XSS) vulnerability discovered by WordFence in WordPress Facebook for WordPress plugin (versions 3.0.0 – 3.0.3).

Solution

Update the WordPress Facebook for WordPress plugin to the latest available version (at least 3.0.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.