API Monitor free
arrow right To plugin page
Fixed

WordPress Ninja Forms plugin <= 3.6.9 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

4.8
CVSS 3.1 score Medium severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Ninja Forms
Type
Plugin
Vulnerable versions
<= 3.6.9
Fixed in
3.6.10
PSID
27d085f7c8e7
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Requires high role user authentication like admin.
Publicly disclosed
2022-06-10

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by Muhammad Adel in WordPress Ninja Forms plugin (versions <= 3.6.9).

Solution

Update the WordPress Ninja Forms plugin to the latest available version (at least 3.6.10).

References

Vulnerability details

Other known vulnerabilities for Ninja Forms

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close