API Monitor free
arrow right To plugin page
Fixed

WordPress Ninja Forms plugin <= 3.4.27 - Cross-Site Request Forgery (CSRF) leading to Arbitrary Plugin Installation vulnerability

CVSS 3.1 score Unknown severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Ninja Forms
Type
Plugin
Vulnerable versions
<= 3.4.27
Fixed in
3.4.27.1
PSID
078f124e925e
CVE ID
N/A
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
Publicly disclosed
2020-09-22

Details

Cross-Site Request Forgery (CSRF) leading to Arbitrary Plugin Installation vulnerability found by Slavco Mihajloski in WordPress Ninja Forms plugin (versions <= 3.4.27).

Solution

Update the WordPress Ninja Forms plugin to the latest available version (at least 3.4.27.1).

References

Vulnerability details Plugin changelog

Other known vulnerabilities for Ninja Forms

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close