API Monitor free
arrow right To plugin page
Fixed

WordPress Ninja Forms Contact Form plugin <= 3.5.8.1 - Stored Cross-Site Scripting (XSS) vulnerability

4.8
CVSS 3.1 score Medium severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Ninja Forms
Type
Plugin
Vulnerable versions
<= 3.5.8.1
Fixed in
3.5.8.2
PSID
6feb7a9b5fa7
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Requires high privilege user authentication like admin.
Publicly disclosed
2021-09-27

Details

Stored Cross-Site Scripting (XSS) vulnerability discovered by Rodel Plasabas in WordPress Ninja Forms Contact Form plugin (versions <= 3.5.8.1).

Solution

Update the WordPress Ninja Forms Contact Form plugin to the latest available version (at least 3.5.8.2).

References

CVE-2021-24381 Vulnerability details Plugin changelog

Other known vulnerabilities for Ninja Forms

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close