WordPress Ninja Forms Contact Form plugin <= 3.5.7 - Unprotected REST-API to Email Injection vulnerability

ninja-forms

Software
Ninja Forms
Vulnerable Versions
<= 3.5.7
Fixed in version
3.5.8
Classification
Other Vulnerability Type
OWASP Top 10
A1: Injection
Disclosure Date
2021-09-22
CVSS 3.0 score

6.5

Medium

Possible for any authenticated user.

Are your websites subject to this vulnerability?

Details

Unprotected REST-API to Email Injection vulnerability discovered by Chloe Chamberland (WordFence) in WordPress Ninja Forms Contact Form plugin (versions <= 3.5.7).

Solution

Update the WordPress Ninja Forms Contact Form plugin to the latest available version (at least 3.5.8).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.