API Monitor free
arrow right To plugin page
Fixed

WordPress Night Mode plugin <= 1.0.0 - Authenticated Persistent Cross-Site Scripting (XSS) vulnerability

4.8
CVSS 3.1 score Medium severity
Monitoring Coming soon

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Night Mode
Type
Plugin
Vulnerable versions
<= 1.0.0
Fixed in
1.4.0
PSID
fb15b557bb98
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Requires high role user authentication like admin.
Publicly disclosed
2022-04-25

Details

Authenticated Persistent Cross-Site Scripting (XSS) vulnerability discovered by Ex.Mi (Patchstack) in WordPress Night Mode plugin (versions <= 1.0.0).

Solution

Update the WordPress Night Mode plugin to the latest available version (at least 1.4.0).

References

CVE-2022-29418 Plugin changelog

No other known vulnerabilities found for Night Mode.
Let us know if we missed something.

Report a vulnerability

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close