WordPress Ni WooCommerce Custom Order Status plugin <= 1.9.6 - SQL Injection (SQLi) vulnerability

ni-woocommerce-custom-order-status

Software
Ni WooCommerce Custom Order Status
Vulnerable Versions
<= 1.9.6
Fixed in version
1.9.7
CVE
CVE-2021-24846
Credits
Classification
SQL Injection
OWASP Top 10
A1: Injection
Disclosure Date
2021-11-22
CVSS 3.0 score

6.3

Medium

Requires subscriber or higher role user authentication.

Are your websites subject to this vulnerability?

Details

SQL Injection (SQLi) vulnerability discovered by JrXnm in WordPress Ni WooCommerce Custom Order Status plugin (versions <= 1.9.6).

Solution

Update the WordPress Ni WooCommerce Custom Order Status plugin to the latest available version (at least 1.9.7).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.