WordPress NextGEN Gallery Pro premium plugin <= 3.1.9 - Reflected Cross-Site Scripting (XSS) vulnerability

nextgen-gallery-pro

Software
NextGEN Gallery Pro
Versions
<= 3.1.9
Disclosure date
2021-02-24
CVE
CVE-N/A
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability found by Thura Moe Myint in WordPress NextGEN Gallery Pro premium plugin (versions <= 3.1.9).

Solution

Update the WordPress NextGEN Gallery Pro premium plugin to the latest available version (at least 3.1.11).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.