WordPress NewStatPress plugin <= 1.3.5 - Reflected Cross-Site Scripting (XSS) vulnerability

newstatpress

Software
NewStatPress
Vulnerable Versions
<= 1.3.5
Fixed in version
1.3.6
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2022-01-13
CVSS 3.0 score

6.1

Medium

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability discovered by Krzysztof Zając in WordPress NewStatPress plugin (versions <= 1.3.5).

Solution

Update the WordPress NewStatPress plugin to the latest available version (at least 1.3.6).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.