WordPress Donations plugin <= 1.8 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

nd-donations

Software
Donations
Vulnerable Versions
<= 1.8
Fixed in version
CVE
CVE-2022-29433
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2022-05-13
CVSS 3.0 score

4.1

Medium

Requires contributor or higher role user authentication.

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by Ngo Van Thien (Patchstack Alliance) WordPress Donations plugin (versions <= 1.8).

Solution

Deactivate and delete. This plugin has been closed as of February 28, 2022 and is not available for download. Reason: Security Issue.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.