Security programs Bounty leaderboard API Protect

WordPress WP OAuth Server Plugin <= 3.0.4 is vulnerable to Bypass Vulnerability

Patch within 30 days Low priority
Not known to be exploited Report an attack
9.8
Critical severity CVSS 3.1 score

Detect and mitigate security vulnerabilities at scale with Patchstack!

Enable Protection

Solution

Update to fix

Update the WordPress WP OAuth Server plugin to the latest available version (at least 4.0.1).

Found this useful? Thank Istv├ín M├írton for reporting this vulnerability. Buy a coffee ☕

Details

Show technical details
Verified

István Márton discovered and reported this Bypass Vulnerability vulnerability in WordPress WP OAuth Server Plugin. A bypass vulnerability could allow a malicious actor to bypass certain restrictions in the code. This vulnerability has been fixed in version 4.0.1.

No other known vulnerabilities for this plugin

Report

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Alliance bounty platform and earn monthly cash prizes.

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close