WordPress WP Media Cleaner Plugin <= 2.2.6 - Multiple XSS

media-cleaner

Software
WP Media Cleaner
Versions
<= 2.2.6
Disclosure date
2015-03-03
CVE
CVE-2015-2195
References
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)

Are your websites subject to this vulnerability?

Details

Because of these vulnerabilities, the attackers can inject arbitrary web script or HTML via the "s", "paged" or "view" parameters in the wp-media-cleaner page to wp-admin/upload.php.

Solution

Update the plugin.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.