API Monitor free
arrow right To plugin page
Fixed

WordPress MC4WP plugin <= 4.8.6 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

4.8
CVSS 3.1 score Medium severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
MC4WP
Type
Plugin
Vulnerable versions
<= 4.8.6
Fixed in
4.8.7
PSID
cb435f78ca13
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Requires high role user authentication like admin.
Publicly disclosed
2022-03-02

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by Asif Nawaz Minhas (Patchstack Alliance) in WordPress MC4WP plugin (versions <= 4.8.6).

Solution

Update the WordPress MC4WP plugin to the latest available version (at least 4.8.7).

References

CVE-2021-36833 Plugin changelog

Other known vulnerabilities for MC4WP

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close