WordPress MC4WP plugin <= 4.8.4 - Unauthorised Actions via Cross-Site Request Forgery (CSRF) vulnerability

mailchimp-for-wp

Software
MC4WP
Versions
<= 4.8.4
Disclosure date
2021-06-01
CVE
CVE-N/A
Credits
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A2: Broken Authentication and Session Management
CVSS 3.0 score

5.4

Medium

Are your websites subject to this vulnerability?

Details

Unauthorised Actions via Cross-Site Request Forgery (CSRF) vulnerability discovered by WPScanTeam in WordPress MC4WP plugin (versions <= 4.8.4).

Solution

Update the WordPress MC4WP plugin to the latest available version (at least 4.8.5).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.