WordPress Kiwi Social Sharing plugin <= 2.1.0 - Unauthenticated WordPress Options Change/Read vulnerability

kiwi-social-share

Software
Kiwi
Versions
<= 2.1.0
Disclosure date
2021-06-04
CVE
CVE-N/A
Credits
Classification
Other Vulnerability Type
OWASP Top 10
A7: Missing Function Level Access Control
CVSS 3.0 score

9.8

Critical

Can be exploited remotely without any authentication.

Are your websites subject to this vulnerability?

Details

Unauthenticated WordPress Options Change/Read vulnerability discovered by NinTechNet in WordPress Kiwi Social Sharing plugin (versions <= 2.1.0).

Solution

Update the WordPress Kiwi Social Sharing plugin to the latest available version (at least 2.1.3).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.