WordPress JupiterX Core Plugin <= 3.3.5 is vulnerable to Arbitrary File Upload

As Jupiter X Core uses the same slug for free and premium versions, you may receive a false positive alert about this vulnerability if you use the free version of the plugin.

Patch priority: high
Resolve immediately High priority
9.0
Critical severity CVSS 3.1 score

Detect and mitigate security vulnerabilities at scale with Patchstack!

Protect now

Solution

Fixed Update to fix
vPatch available vPatch available

Update the WordPress JupiterX Core plugin to the latest available version (at least 3.3.8).

Found this useful? Thank Rafie Muhammad (Patchstack) for reporting this vulnerability. Buy a coffee ☕

Details

Show technical details
Published by Patchstack

As Jupiter X Core uses the same slug for free and premium versions, you may receive a false positive alert about this vulnerability if you use the free version of the plugin.

Rafie Muhammad (Patchstack) discovered and reported this Arbitrary File Upload vulnerability in WordPress JupiterX Core Plugin. This could allow a malicious actor to upload any type of file to your website. This can include backdoors which are then executed to gain further access to your website. This vulnerability has been fixed in version 3.3.8.

This vulnerability was reported to and published by Patchstack. Our users receive alerts and protections up to 48 hours in advance.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

1 present
7 fixed
View all
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu