WordPress IWantOneButton Plugin 3.0.1 - Multiple Vulnerabilities

iwantonebutton

Software
IWantOneButton
Versions
3.0.1
Disclosure date
2011-02-24
CVE
CVE-N/A
References
Classification
Multiple Vulnerabilities
OWASP Top 10

Are your websites subject to this vulnerability?

Details

There are several vulnerabilities in this plugin. First vulnerability type is SQL injection. The vulnerability exists because of failure in the "/wp-content/plugins/iwant-one-ihave-one/updateAJAX.php" script to properly clean up user-supplied input in "post_id" variable. It allows an attacker to modify data, alter queries to the application SQL database, compromise the access and application or exploit hidden vulnerabilities in the underlying database. Second vulnerability type is cross-site scripting. The vulnerability exists because of in the "/wp-content/plugins/iwant-one-ihave-one/updateAJAX.php" script to properly sanitize user-supplied input in "post_id" variable. It results that the attacker can steal cookie-based authentication credentials, modificate or disclosure important data.

Solution

Update the plugin.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.