WordPress Inline Related Posts plugin <= 3.0.4 - Cross-Site Scripting (XSS) vulnerability

intelly-related-posts

Software
Inline Related Posts
Vulnerable Versions
<= 3.0.4
Fixed in version
3.0.5
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-10-09
CVSS 3.0 score

6.9

Medium

Requires high privilege user authentication like admin.

Are your websites subject to this vulnerability?

Details

Cross-Site Scripting (XSS) vulnerability discovered by Martin Vierula (Trustwave) in WordPress Inline Related Posts plugin (versions <= 3.0.4).

Solution

Update the WordPress Inline Related Posts plugin to the latest available version (at least 3.0.5).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.