WordPress Icegram plugin <= 2.0.2 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

icegram

Software
Icegram
Vulnerable Versions
<= 2.0.2
Fixed in version
2.0.3
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-08-17
CVSS 3.0 score

4.8

Medium

Requires high privilege user authentication like admin.

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by Asif Nawaz Minhas in WordPress Icegram plugin (versions <= 2.0.2). Vulnerable at "Headline" (&message_data[16][headline]) input.

Solution

Update the WordPress Icegram plugin to the latest available version (at least 2.0.3).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.