WordPress I Recommend This Plugin <= 3.8.3 is vulnerable to Cross Site Scripting (XSS)

This plugin was still closed for Security Reason as of October 27th 2023. A patch was added in plugin version 3.9.0, but this version isn't available yet. Alternatively, it can be downloaded at https://github.com/webtions/i-recommend-this/releases/tag/3.9.0

Patch priority: low
Resolve by 19 May, 2023 Low priority
5.9
Medium severity CVSS 3.1 score

Patchstack is the official security point of contact for this software.

Protect now

Patchstack is the official security point of contact for WordPress I Recommend This plugin.

Solution

Fixed Update to fix

Update the WordPress I Recommend This plugin to the latest available version (at least 3.9.0).

Found this useful? Thank Rio Darmawan for reporting this vulnerability. Buy a coffee ☕

Details

Show technical details
Published by Patchstack

This plugin was still closed for Security Reason as of October 27th 2023. A patch was added in plugin version 3.9.0, but this version isn't available yet. Alternatively, it can be downloaded at https://github.com/webtions/i-recommend-this/releases/tag/3.9.0

Rio Darmawan discovered and reported this Cross Site Scripting (XSS) vulnerability in WordPress I Recommend This Plugin. This could allow a malicious actor to inject malicious scripts, such as redirects, advertisements, and other HTML payloads into your website which will be executed when guests visit your site. This vulnerability has been fixed in version 3.9.0.

This vulnerability was reported to and published by Patchstack. Our users receive alerts and protections up to 48 hours in advance.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

1 present
2 fixed
View all
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu