WordPress Hide My WP premium plugin <= 6.2.3 - Unauthenticated Plugin Deactivation vulnerability

hide-my-wp

Software
Hide My WP
Vulnerable Versions
<= 6.2.3
Fixed in version
6.2.4
Classification
Other Vulnerability Type
OWASP Top 10
A5: Broken Access Control
Disclosure Date
2021-11-24
CVSS 3.0 score

6.5

Medium

Can be exploited remotely without any authentication.

Are your websites subject to this vulnerability?

Details

Unauthenticated Plugin Deactivation vulnerability discovered by Dave Jong in WordPress Hide My WP premium plugin (versions <= 6.2.3).

Solution

Update the WordPress Hide My WP premium plugin to the latest available version (at least 6.2.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.