WordPress HashThemes Demo Importer plugin <= 1.1.1 - Improper Access Control allowing content deletion vulnerability

hashthemes-demo-importer

Software
HashThemes Demo Importer
Vulnerable Versions
<= 1.1.1
Fixed in version
1.1.2
Classification
Arbitrary Content Deletion
OWASP Top 10
A5: Broken Access Control
Disclosure Date
2021-10-26
CVSS 3.0 score

8.1

High

Possible with low privilege user role like Subscriber.

Are your websites subject to this vulnerability?

Details

Improper Access Control allowing content deletion vulnerability discovered by Ramuel Gall (WordFence) in WordPress HashThemes Demo Importer plugin (versions <= 1.1.1).

Solution

Update the WordPress HashThemes Demo Importer plugin to the latest available version (at least 1.1.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.