WordPress Gwolle Guestbook plugin <= 4.1.2 - Reflected Cross-Site Scripting (XSS) vulnerability

gwolle-gb

Software
Gwolle Guestbook
Vulnerable Versions
<= 4.1.2
Fixed in version
4.2.0
CVE
CVE-2021-24980
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-11-23
CVSS 3.0 score

4.7

Medium

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability discovered by JrXnm in WordPress Gwolle Guestbook plugin (versions <= 4.1.2).

Solution

Update the WordPress Gwolle Guestbook plugin to the latest available version (at least 4.2.0).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.