WordPress Andrea Pernici News Sitemap for Google plugin <= 1.0.16 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

google-news-sitemap

Software
Andrea Pernici News Sitemap for Google
Vulnerable Versions
<= 1.0.16
Fixed in version
CVE
CVE-2021-36912
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2022-05-04
CVSS 3.0 score

5.4

Medium

Requires contributor or higher role user authentication.

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by John Castro aka mirphak (Pagely) in WordPress Andrea Pernici News Sitemap for Google plugin (versions <= 1.0.16).

Solution

No patched version is available.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.