WordPress Glass plugin <= 1.3.2 - Cross-Site Request Forgery (CSRF) vulnerability leading to Stored Cross-Site Scripting (XSS)

glass

Software
Glass
Vulnerable Versions
<= 1.3.2
Fixed in version
CVE
CVE-2021-24434
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-06-21
CVSS 3.0 score

5.4

Medium

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Stored Cross-Site Scripting (XSS) discovered by ABISHEIK M in WordPress Glass plugin (versions <= 1.3.2).

Solution

This plugin has been closed as of May 26, 2021 and is not available for download. This closure is temporary, pending a full review.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.