Bounty Leaderboard API Enable Protection

WordPress GiveWP Plugin <= 2.25.1 is vulnerable to Arbitrary Content Deletion

Medium severity CVSS 3.1 score
Not known to be exploited Report an attack

Protect your sites with automated security

Enable Protection



Update the WordPress GiveWP plugin to the latest available version (at least 2.25.2).

Found this useful? Thank Rafshanzani Suhada for reporting this vulnerability. Buy a coffee ☕


Show technical details

Rafshanzani Suhada discovered and reported this Arbitrary Content Deletion vulnerability in WordPress GiveWP Plugin. This could allow a malicious actor to delete content from your website such as pictures, posts or pages. This vulnerability has been fixed in version 2.25.2.

Other vulnerabilities in this plugin

0 present
25 patched
View all

Report to Patchstack Alliance bounty platform and earn monthly cash prizes.

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close