WordPress GiveWP plugin <= 2.10.1 - Authenticated Persistent Cross-Site Scripting (XSS) vulnerability

give

Software
GiveWP
Versions
<= 2.10.1
Disclosure date
2021-04-21
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)
CVSS 3.0 score

6.5

Medium

Are your websites subject to this vulnerability?

Details

Authenticated Persistent Cross-Site Scripting (XSS) vulnerability discovered by m0ze (Patchstack Red Team) in WordPress GiveWP plugin (versions <= 2.10.1).

Solution

Update the WordPress GiveWP plugin to the latest available version (at least 2.10.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.