WordPress FooGallery plugin <= 2.0.30 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

foogallery

Software
FooGallery
Versions
<= 2.0.30
Disclosure date
2021-05-31
CVE
CVE-2021-24357
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
CVSS 3.0 score

4.8

Medium

Requires admin authentication.

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by avolume in WordPress FooGallery plugin (versions <= 2.0.30).

Solution

Update the WordPress FooGallery plugin to the latest available version (at least 2.0.35)

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.