WordPress Five Star Restaurant Menu plugin <= 2.2.0 - Unauthenticated Remote Code Execution (RCE) vulnerability

food-and-drink-menu

Software
Five Star Restaurant Menu
Versions
<= 2.2.0
Disclosure date
2021-03-10
CVE
CVE-2020-29045
Credits
Classification
Arbitrary Code Execution
OWASP Top 10
A1: Injection

Are your websites subject to this vulnerability?

Details

Unauthenticated Remote Code Execution (RCE) vulnerability discovered by Nick Blundell in WordPress Five Star Restaurant Menu plugin (versions <= 2.2.0).

Solution

Update the WordPress Five Star Restaurant Menu plugin to the latest available version (at least 2.2.1).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.