WordPress Contact Form Plugin by Fluent Forms <= 3.6.65 - Cross-Site Request Forgery (CSRF) vulnerability leading to stored Cross-Site Scripting (XSS)

fluentform

Software
Contact Form Plugin
Vulnerable Versions
<= 3.6.65
Fixed in version
3.6.67
CVE
CVE-2021-34620
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
Disclosure Date
2021-06-16
CVSS 3.0 score

7.1

High

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to stored Cross-Site Scripting (XSS) discovered by Ramuel Gall (WordFence) in WordPress Contact Form Plugin by Fluent Forms (versions <= 3.6.65).

Solution

Update the WordPress Contact Form Plugin by Fluent Forms to the latest available version (at least 3.6.67).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.