WordPress FireStats Plugin 1.0.2 - Multiple Cross-Site Scripting and Authentication Bypass Vulnerabilities

firestats

Software
FireStats
Versions
<= 1.0.2
Disclosure date
2009-11-24
CVE
CVE-N/A
References
Credits
Classification
Multiple Vulnerabilities
OWASP Top 10

Are your websites subject to this vulnerability?

Details

FireStats plugin is prone to multiple cross-site scripting vulnerabilities and an authentication BYPASS vulnerabilities. An attacker may gain unauthorized access to the affected application and execute arbitrary script code in the context of the affected site. In that way the attacker can steal cookie-based authentication credits. And the other attacks are possible too.

Solution

Upgrade the plugin.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.