WordPress External Media plugin <= 1.0.33 - Authenticated Arbitrary File Upload vulnerability leading to Remote Code Execution (RCE)

external-media

Software
External Media
Versions
<= 1.0.33
Disclosure date
2021-05-13
CVE
CVE-N/A
Credits
Classification
Arbitrary File Upload
OWASP Top 10
A1: Injection
CVSS 3.0 score

9.9

Critical

Possible with "Subscriber" or any higher user role.

Are your websites subject to this vulnerability?

Details

Authenticated Arbitrary File Upload vulnerability leading to Remote Code Execution (RCE) discovered by WordFence in WordPress External Media plugin (versions <= 1.0.33).

Solution

Update the WordPress External Media plugin to the latest available version (at least 1.0.34).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.