Security programs Bounty leaderboard API Protect

WordPress Essential Addons for Elementor Plugin <= 5.8.8 is vulnerable to Privilege Escalation

Patch immediately High priority
Not known to be exploited Report an attack
High severity CVSS 3.1 score

Patchstack automatically mitigates this vulnerability with a vPatch.

Enable Protection

Patchstack is the official security point of contact for WordPress Essential Addons for Elementor plugin.


Update to fix
vPatch available

Update the WordPress Essential Addons for Elementor plugin to the latest available version (at least 5.8.9).

Found this useful? Thank Rafie Muhammad (Patchstack) for reporting this vulnerability. Buy a coffee ☕


Show technical details

Rafie Muhammad (Patchstack) discovered and reported this Privilege Escalation vulnerability in WordPress Essential Addons for Elementor Plugin. This could allow a malicious actor to escalate their low privileged account to something with higher privileges. After this they could take full control of the website if high privileges are gained. This vulnerability has been fixed in version 5.8.9.

Other vulnerabilities in this plugin

0 present
6 patched
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Alliance bounty platform and earn monthly cash prizes.

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close