Security programs Bounty leaderboard API Protect

WordPress Elementor Website Builder Plugin <= 3.5.5 is vulnerable to Cross Site Scripting (XSS)

Patch within 7 days Medium priority
Not known to be exploited Report an attack
Medium severity CVSS 3.1 score

Patchstack is the official security point of contact for this software.

Enable Protection

Patchstack is the official security point of contact for WordPress Elementor Website Builder plugin.


Update to fix

Update the WordPress Elementor plugin to the latest available version (at least 3.5.6).


Show technical details

Rotem Bar discovered and reported this Cross Site Scripting (XSS) vulnerability in WordPress Elementor Website Builder Plugin. This could allow a malicious actor to inject malicious scripts, such as redirects, advertisements, and other HTML payloads into your website which will be executed when guests visit your site. This vulnerability has been fixed in version 3.5.6.

Other vulnerabilities in this plugin

0 present
15 patched
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Alliance bounty platform and earn monthly cash prizes.

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close